const regex = /(?i)\[\[(?!(assets|Bücher|Dokumente|Dokumenttyp|epsilon_notes|kontakte|literatur|Proj|Test|Wissen|WV)(?:[\w_]*)\/)(?<firstlevelfolder>[^\/\|#\]]*\/)?(?<bildpfad>[^\|\\\]#]+)(\\\||\||#)*(?<bildattribut>[^\]]*)\]\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\[\\[(?!(assets|Bücher|Dokumente|Dokumenttyp|epsilon_notes|kontakte|literatur|Proj|Test|Wissen|WV)(?:[\\w_]*)\\\/)(?<firstlevelfolder>[^\\\/\\|#\\]]*\\\/)?(?<bildpfad>[^\\|\\\\\\]#]+)(\\\\\\||\\||#)*(?<bildattribut>[^\\]]*)\\]\\]', 'gm')
const str = `Link zum Bild:
![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg]]
![[subfolder/image.png|100x100]]
![[subfolder/sub2/image.png|100x100]]
![[../../ima/ge.png|100x100]]
![[Projekte/image.png|100x100]]
![[Projekte/image.Png|100x100]]
[[assets/MiSZ 2T.pdf]]
[[assets2/MiSZ 2T.pdf]]
![[Projekte/Mikroskop/Leica, Wild/Product Guide for Stereomicroscopes. Living up to Life.pdf]]
![[BA_GSZ 2_GSZ 2T.pdf#page=7]]
![[BA_GSZ 2_GSZ 2T.pdf]]
Beispiel-tabelle:
Caption1 | Caption2 |
---|---|
Content1 text | Link innerhalb Tabelle mit Attributen
![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\\|300]] |
vorerst letzte Zeile | Text Text Text |
![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\\|200]]`;
const subst = `[<span style="color:red">CompProc_LinkToFileNonAbsoluteLink:** </span> <span style="background-color: #ff9898; color:blue">**${firstlevelfolder}**${bildpfad}</span>](${firstlevelfolder}${bildpfad})`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);