# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)\[\[(?!(assets|Bücher|Dokumente|Dokumenttyp|epsilon_notes|kontakte|literatur|Proj|Test|Wissen|WV)(?:[\w_]*)\/)(?<firstlevelfolder>[^\/\|#\]]*\/)?(?<bildpfad>[^\|\\\]#]+)(\\\||\||#)*(?<bildattribut>[^\]]*)\]\]"
test_str = ("Link zum Bild:\n"
"![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg]]\n\n"
"![[subfolder/image.png|100x100]]\n"
"![[subfolder/sub2/image.png|100x100]]\n"
"![[../../ima/ge.png|100x100]]\n"
"![[Projekte/image.png|100x100]]\n"
"![[Projekte/image.Png|100x100]]\n"
" \n"
"[[assets/MiSZ 2T.pdf]]\n"
"[[assets2/MiSZ 2T.pdf]]\n"
"![[Projekte/Mikroskop/Leica, Wild/Product Guide for Stereomicroscopes. Living up to Life.pdf]]\n"
"![[BA_GSZ 2_GSZ 2T.pdf#page=7]]\n"
"![[BA_GSZ 2_GSZ 2T.pdf]]\n\n"
"Beispiel-tabelle:\n"
"Caption1 | Caption2 |\n"
"---|---|\n"
"Content1 text | Link innerhalb Tabelle mit Attributen\n"
"![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\\|300]] |\n"
"vorerst letzte Zeile | Text Text Text |\n\n"
"![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\\|200]]")
subst = "[<span style=\"color:red\">CompProc_LinkToFileNonAbsoluteLink:** </span> <span style=\"background-color: #ff9898; color:blue\">**${firstlevelfolder}**${bildpfad}</span>](${firstlevelfolder}${bildpfad})"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.