import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<div class=\"[^\"]*?\\menu\\b[^\"]*?\">.*?<\\/div>)";
final String string = "<div class=\"menu\">\n"
+ " <div class=\"innermenu pagewidth\">\n"
+ " <div class=\"leftside\"></div>\n"
+ " <ul>\n"
+ " <li class=\"parent\" >\n"
+ " <h3>\n"
+ " <a href=\"#\" title=\"Menu\" id=\"headlink4\" class=\"spanhover mainlevel\">\n"
+ " <span>Menu</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " <div class=\"submenu level1\">\n"
+ " <ul class=\"level1\">\n"
+ " <li class=\"parent\" id=\"hcategory_1\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/Szyby-nowe/1.html\"\n"
+ " title=\"Szyby nowe\" id=\"headercategory1\" class=\"spanhover\">\n"
+ " <span>Szyby nowe</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " <div class=\"submenu level2\">\n"
+ " <ul class=\"level2\">\n"
+ " <li class=\"\" id=\"hcategory_7\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/ACURA/7.html\"\n"
+ " title=\"ACURA\" id=\"headercategory7\" class=\"spanhover\">\n"
+ " <span>ACURA</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_8\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/AUDI/8.html\"\n"
+ " title=\"AUDI\" id=\"headercategory8\" class=\"spanhover\">\n"
+ " <span>AUDI</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_9\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/BMW/9.html\"\n"
+ " title=\"BMW\" id=\"headercategory9\" class=\"spanhover\">\n"
+ " <span>BMW</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_40\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/BUICK/40.html\"\n"
+ " title=\"BUICK\" id=\"headercategory40\" class=\"spanhover\">\n"
+ " <span>BUICK</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_10\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/CADILLAC/10.html\"\n"
+ " title=\"CADILLAC\" id=\"headercategory10\" class=\"spanhover\">\n"
+ " <span>CADILLAC</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_11\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/CHEVROLET/11.html\"\n"
+ " title=\"CHEVROLET\" id=\"headercategory11\" class=\"spanhover\">\n"
+ " <span>CHEVROLET</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_14\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/CHRYSLER/14.html\"\n"
+ " title=\"CHRYSLER\" id=\"headercategory14\" class=\"spanhover\">\n"
+ " <span>CHRYSLER</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_46\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/CITROEN/46.html\"\n"
+ " title=\"CITROEN\" id=\"headercategory46\" class=\"spanhover\">\n"
+ " <span>CITROEN</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_15\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/DODGE/15.html\"\n"
+ " title=\"DODGE\" id=\"headercategory15\" class=\"spanhover\">\n"
+ " <span>DODGE</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_44\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/FIAT/44.html\"\n"
+ " title=\"FIAT\" id=\"headercategory44\" class=\"spanhover\">\n"
+ " <span>FIAT</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_16\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/FORD/16.html\"\n"
+ " title=\"FORD\" id=\"headercategory16\" class=\"spanhover\">\n"
+ " <span>FORD</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_12\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/GMC/12.html\"\n"
+ " title=\"GMC\" id=\"headercategory12\" class=\"spanhover\">\n"
+ " <span>GMC</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_17\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/HONDA/17.html\"\n"
+ " title=\"HONDA\" id=\"headercategory17\" class=\"spanhover\">\n"
+ " <span>HONDA</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_18\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/HUMMER/18.html\"\n"
+ " title=\"HUMMER\" id=\"headercategory18\" class=\"spanhover\">\n"
+ " <span>HUMMER</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_19\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/HYUNDAI/19.html\"\n"
+ " title=\"HYUNDAI\" id=\"headercategory19\" class=\"spanhover\">\n"
+ " <span>HYUNDAI</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_20\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/INFINITI/20.html\"\n"
+ " title=\"INFINITI\" id=\"headercategory20\" class=\"spanhover\">\n"
+ " <span>INFINITI</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_13\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/ISUZU/13.html\"\n"
+ " title=\"ISUZU\" id=\"headercategory13\" class=\"spanhover\">\n"
+ " <span>ISUZU</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_21\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/JAGUAR/21.html\"\n"
+ " title=\"JAGUAR\" id=\"headercategory21\" class=\"spanhover\">\n"
+ " <span>JAGUAR</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_22\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/JEEP/22.html\"\n"
+ " title=\"JEEP\" id=\"headercategory22\" class=\"spanhover\">\n"
+ " <span>JEEP</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_23\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/KIA/23.html\"\n"
+ " title=\"KIA\" id=\"headercategory23\" class=\"spanhover\">\n"
+ " <span>KIA</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_45\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/LANCIA/45.html\"\n"
+ " title=\"LANCIA\" id=\"headercategory45\" class=\"spanhover\">\n"
+ " <span>LANCIA</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_24\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/LAND-ROVER/24.html\"\n"
+ " title=\"LAND ROVER\" id=\"headercategory24\" class=\"spanhover\">\n"
+ " <span>LAND ROVER</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_25\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/LEXUS/25.html\"\n"
+ " title=\"LEXUS\" id=\"headercategory25\" class=\"spanhover\">\n"
+ " <span>LEXUS</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_38\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/LINCOLN/38.html\"\n"
+ " title=\"LINCOLN\" id=\"headercategory38\" class=\"spanhover\">\n"
+ " <span>LINCOLN</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_26\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/MAZDA/26.html\"\n"
+ " title=\"MAZDA\" id=\"headercategory26\" class=\"spanhover\">\n"
+ " <span>MAZDA</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_27\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/MERCEDES-BENZ/27.html\"\n"
+ " title=\"MERCEDES BENZ\" id=\"headercategory27\" class=\"spanhover\">\n"
+ " <span>MERCEDES BENZ</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_48\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/MERCURY/48.html\"\n"
+ " title=\"MERCURY\" id=\"headercategory48\" class=\"spanhover\">\n"
+ " <span>MERCURY</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_28\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/MITSUBISHI/28.html\"\n"
+ " title=\"MITSUBISHI\" id=\"headercategory28\" class=\"spanhover\">\n"
+ " <span>MITSUBISHI</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_29\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/NISSAN/29.html\"\n"
+ " title=\"NISSAN\" id=\"headercategory29\" class=\"spanhover\">\n"
+ " <span>NISSAN</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_41\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/OLDSMOBILE/41.html\"\n"
+ " title=\"OLDSMOBILE\" id=\"headercategory41\" class=\"spanhover\">\n"
+ " <span>OLDSMOBILE</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_30\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/OPEL/30.html\"\n"
+ " title=\"OPEL\" id=\"headercategory30\" class=\"spanhover\">\n"
+ " <span>OPEL</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_47\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/PEUGEOT/47.html\"\n"
+ " title=\"PEUGEOT\" id=\"headercategory47\" class=\"spanhover\">\n"
+ " <span>PEUGEOT</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_43\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/PONTIAC/43.html\"\n"
+ " title=\"PONTIAC\" id=\"headercategory43\" class=\"spanhover\">\n"
+ " <span>PONTIAC</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_31\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/PORSCHE/31.html\"\n"
+ " title=\"PORSCHE\" id=\"headercategory31\" class=\"spanhover\">\n"
+ " <span>PORSCHE</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_32\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/RANGE-ROVER/32.html\"\n"
+ " title=\"RANGE ROVER\" id=\"headercategory32\" class=\"spanhover\">\n"
+ " <span>RANGE ROVER</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_33\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/SAAB/33.html\"\n"
+ " title=\"SAAB\" id=\"headercategory33\" class=\"spanhover\">\n"
+ " <span>SAAB</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_42\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/SATURN/42.html\"\n"
+ " title=\"SATURN\" id=\"headercategory42\" class=\"spanhover\">\n"
+ " <span>SATURN</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_34\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/SUBARU/34.html\"\n"
+ " title=\"SUBARU\" id=\"headercategory34\" class=\"spanhover\">\n"
+ " <span>SUBARU</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_35\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/SUZUKI/35.html\"\n"
+ " title=\"SUZUKI\" id=\"headercategory35\" class=\"spanhover\">\n"
+ " <span>SUZUKI</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_36\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/TOYOTA/36.html\"\n"
+ " title=\"TOYOTA\" id=\"headercategory36\" class=\"spanhover\">\n"
+ " <span>TOYOTA</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_37\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/VOLKSWAGEN/37.html\"\n"
+ " title=\"VOLKSWAGEN\" id=\"headercategory37\" class=\"spanhover\">\n"
+ " <span>VOLKSWAGEN</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_39\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/VOLVO/39.html\"\n"
+ " title=\"VOLVO\" id=\"headercategory39\" class=\"spanhover\">\n"
+ " <span>VOLVO</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " </ul>\n"
+ " </div> </li>\n"
+ " <li class=\"\" id=\"hcategory_2\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/Szyby-uzywane/2.html\"\n"
+ " title=\"Szyby używane\" id=\"headercategory2\" class=\"spanhover\">\n"
+ " <span>Szyby używane</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_3\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/Czesci-samochodowe/3.html\"\n"
+ " title=\"Części samochodowe\" id=\"headercategory3\" class=\"spanhover\">\n"
+ " <span>Części samochodowe</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_5\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/Zabezpieczenia-do-motocykli-i-rowerow/5.html\"\n"
+ " title=\"Zabezpieczenia do motocykli i rowerów\" id=\"headercategory5\" class=\"spanhover\">\n"
+ " <span>Zabezpieczenia do motocykli i rowerów</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " <li class=\"\" id=\"hcategory_4\">\n"
+ " <h3>\n"
+ " <a href=\"pl/c/Samochody/4.html\"\n"
+ " title=\"Samochody\" id=\"headercategory4\" class=\"spanhover\">\n"
+ " <span>Samochody</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li>\n"
+ " </ul>\n"
+ " </div> </li> <li class=\"\" >\n"
+ " <h3>\n"
+ " <a href=\"pl/i/Regulamin/2.html\" title=\"Regulamin\" id=\"headlink1\" class=\"spanhover mainlevel\">\n"
+ " <span>Regulamin</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li> <li class=\"\" >\n"
+ " <h3>\n"
+ " <a href=\"pl/contact.html\" title=\"Formularz kontaktowy\" id=\"headlink2\" class=\"spanhover mainlevel\">\n"
+ " <span>Formularz kontaktowy</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li> <li class=\"\" >\n"
+ " <h3>\n"
+ " <a href=\"pl/i/Polityka-prywatnosci/3.html\" title=\"Polityka prywatności\" id=\"headlink3\" class=\"spanhover mainlevel\">\n"
+ " <span>Polityka prywatności</span>\n"
+ " <img src=\"public/images/1px.gif\" alt=\"\" class=\"px1\" />\n"
+ " </a>\n"
+ " </h3>\n"
+ " </li> </ul>\n"
+ " <div class=\"rightside\"></div>\n"
+ " </div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}