using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?=[A-Z]+=\d+,[A-Z]+=\d+,[A-Z]+=\d+\})(?=[^}]*\bAU=17\b)(?=[^}]*\bBVW=2\b)(?=[^}]*\bCXYZ=321\b)";
string input = @"{AU=17,BVW=2,CXYZ=321}
{BVW=2,CXYZ=321,AU=17}
{CXYZ=321,AU=17,BVW=2}
{AU=170,BVW=2,CXYZ=321}
{AU=17,BVW=2,CXYZT=321}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}