use strict;
my $str = '{AU=17,BVW=2,CXYZ=321}
{BVW=2,CXYZ=321,AU=17}
{CXYZ=321,AU=17,BVW=2}
{AU=170,BVW=2,CXYZ=321}
{AU=17,BVW=2,CXYZT=321}';
my $regex = qr/\{(?=[A-Z]+=\d+,[A-Z]+=\d+,[A-Z]+=\d+\})(?=[^}]*\bAU=17\b)(?=[^}]*\bBVW=2\b)(?=[^}]*\bCXYZ=321\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}