using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s,][^,]*(?=(?:,[^,]*){0,2}$)";
string input = @"V1, V2, V3, V4, V5, V6, V7, V8, V9, V10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}