const regex = /[^\s,][^,]*(?=(?:,[^,]*){0,2}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s,][^,]*(?=(?:,[^,]*){0,2}$)', 'gm')
const str = `V1, V2, V3, V4, V5, V6, V7, V8, V9, V10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}