package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<url>(?:(?<scheme>[a-zA-Z]+:\/\/)?(?<hostname>(?:[-a-zA-Z0-9À-ÖØ-öø-ÿ@%_\+~#=]{1,256}\.){1,256}(?:[-a-zA-Z0-9À-ÖØ-öø-ÿ@%_\+~#=]{1,256})))(?::(?<port>[[:digit:]]+))?(?<path>(?:\/[-a-zA-Z0-9!$&'()*+,\\\/:;=@\[\]._~%]*)*)(?<query>(?:(?:\#|\?)[-a-zA-Z0-9!$&'()*+,\\\/:;=@\[\]._~]*)*))`)
var str = `example.com
www.example.com
www.example.com:81
example.com/file.txt?version=2.1&download=true
https://www.example.com/file.txt
https://www.example.com
https://www.example.com:8443
stfp://example.com:21
http://www.example.com/file.txt?version=2.1&download=true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}