const regex = /(?<url>(?:(?<scheme>[a-zA-Z]+:\/\/)?(?<hostname>(?:[-a-zA-Z0-9À-ÖØ-öø-ÿ@%_\+~#=]{1,256}\.){1,256}(?:[-a-zA-Z0-9À-ÖØ-öø-ÿ@%_\+~#=]{1,256})))(?::(?<port>[[:digit:]]+))?(?<path>(?:\/[-a-zA-Z0-9!$&'()*+,\\\/:;=@\[\]._~%]*)*)(?<query>(?:(?:\#|\?)[-a-zA-Z0-9!$&'()*+,\\\/:;=@\[\]._~]*)*))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<url>(?:(?<scheme>[a-zA-Z]+:\\\/\\\/)?(?<hostname>(?:[-a-zA-Z0-9À-ÖØ-öø-ÿ@%_\\+~#=]{1,256}\\.){1,256}(?:[-a-zA-Z0-9À-ÖØ-öø-ÿ@%_\\+~#=]{1,256})))(?::(?<port>[[:digit:]]+))?(?<path>(?:\\\/[-a-zA-Z0-9!$&\'()*+,\\\\\\\/:;=@\\[\\]._~%]*)*)(?<query>(?:(?:\\#|\\?)[-a-zA-Z0-9!$&\'()*+,\\\\\\\/:;=@\\[\\]._~]*)*))', 'gi')
const str = `example.com
www.example.com
www.example.com:81
example.com/file.txt?version=2.1&download=true
https://www.example.com/file.txt
https://www.example.com
https://www.example.com:8443
stfp://example.com:21
http://www.example.com/file.txt?version=2.1&download=true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}