using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I have some text here[\s\S\w\W\d\D]+>(\d{1,2})<";
string input = @"818y1873+130I have some text here09 124i10029102lsdgn2in3>31<
mkm1ikm12klni12m4j12??=?!=I""=and then some text heremsiJR310>39<0MK)==!)=""!";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}