// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"I have some text here[\s\S\w\W\d\D]+>(\d{1,2})<").unwrap();
let string = "818y1873+130I have some text here09 124i10029102lsdgn2in3>31<
mkm1ikm12klni12m4j12??=?!=I\"=and then some text heremsiJR310>39<0MK)==!)=\"!";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}