const regex = /\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\d+\\-\\d{2}\\.\\d{4}\\.\\d\\.\\d{2}\\.\\d{4}\\s*', 'gm')
const str = ` Processo nº: 0002192-73.2007.8.05.0250`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}