re = /\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*/m
str = ' Processo nº: 0002192-73.2007.8.05.0250'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end