import re
regex = re.compile(r"\s*\d+\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\s*", flags=re.MULTILINE)
test_str = " Processo nº: 0002192-73.2007.8.05.0250"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")