#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\d{3})*|[0]*)(\.\d+)?)\b$"
Local $sString = "0.3" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"000691965" & @CRLF & _
"1,324,125.03" & @CRLF & _
"0,324,125.03" & @CRLF & _
"-1,324,125.03" & @CRLF & _
"abcd123" & @CRLF & _
"1.2.5" & @CRLF & _
"1234abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")