import re
regex = re.compile(r"(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\d{3})*|[0]*)(\.\d+)?)\b$", flags=re.MULTILINE)
test_str = ("0.3\n"
"1\n"
"3\n"
"000691965\n"
"1,324,125.03\n"
"0,324,125.03\n"
"-1,324,125.03\n"
"abcd123\n"
"1.2.5\n"
"1234abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")