re = /(?<IsNumeric>^[+-]?([1-9]*|[1-9]{1,3}(,\d{3})*|[0]*)(\.\d+)?)\b$/m
str = '0.3
1
3
000691965
1,324,125.03
0,324,125.03
-1,324,125.03
abcd123
1.2.5
1234abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end