#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(.*?)\s*$"
Local $sString = "This" & @CRLF & _
"is the" & @CRLF & _
"text I want" & @CRLF & _
"to print" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)