re = /(.*?)\s*$/
str = 'This
is the
text I want
to print
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result