import re
regex = re.compile(r"(.*?)\s*$", flags=re.DOTALL)
test_str = ("This\n"
"is the\n"
"text I want\n"
"to print\n\n\n"
" \n"
" \n"
" \n\n"
" \n"
" \n\n\n"
" \n\n\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)