#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!') *+\[[^\]]*\] *+(?!')"
Local $sString = "[field1] = 'id1'" & @CRLF & _
"[field1] = '[field2]'" & @CRLF & _
"[ field1 ] = '[field2]'" & @CRLF & _
"[field1] = ' [field2] '" & @CRLF & _
"[field1] = ' [field2] ' And [field3] = '[field4] '' [field5]'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")