re = /(?<!') *+\[[^\]]*\] *+(?!')/
str = '[field1] = \'id1\'
[field1] = \'[field2]\'
[ field1 ] = \'[field2]\'
[field1] = \' [field2] \'
[field1] = \' [field2] \' And [field3] = \'[field4] \'\' [field5]\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end