$re = '/(?<!\') *+\[[^\]]*\] *+(?!\')/';
$str = '[field1] = \'id1\'
[field1] = \'[field2]\'
[ field1 ] = \'[field2]\'
[field1] = \' [field2] \'
[field1] = \' [field2] \' And [field3] = \'[field4] \'\' [field5]\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);