using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"wx\.data\.(?!update|get)[^.\n]+";
string input = @"wx.data.xxx
but not
wx.data.update
wx.data.get";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}