re = /wx\.data\.(?!update|get)[^.\n]+/m
str = 'wx.data.xxx
but not
wx.data.update
wx.data.get'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end