$re = '/wx\.data\.(?!update|get)[^.\n]+/m';
$str = 'wx.data.xxx
but not
wx.data.update
wx.data.get';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);