using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?((?:[^\/\.]+\.)*)([^\/\.]+\.[^\/\.]+)((\/\w+)*)?";
string input = @"example1.com/
https://example2.com/
http://example3.com/
https://example4.com/path/to/resource/
http://example5.domain.com/
https://example6.domain.com/path1/path2/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}