package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/)?((?:[^\/\.]+\.)*)([^\/\.]+\.[^\/\.]+)((\/\w+)*)?`)
var str = `example1.com/
https://example2.com/
http://example3.com/
https://example4.com/path/to/resource/
http://example5.domain.com/
https://example6.domain.com/path1/path2/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}