const regex = /(?:https?:\/\/)?((?:[^\/\.]+\.)*)([^\/\.]+\.[^\/\.]+)((\/\w+)*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?((?:[^\\\/\\.]+\\.)*)([^\\\/\\.]+\\.[^\\\/\\.]+)((\\\/\\w+)*)?', 'gm')
const str = `example1.com/
https://example2.com/
http://example3.com/
https://example4.com/path/to/resource/
http://example5.domain.com/
https://example6.domain.com/path1/path2/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}