package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:Bear|Town|Red)`)
var str = `RedWings-223123-NY
Townmansion-2341322-KY
BearingWays-23422-DC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}