$re = '/^(?:Bear|Town|Red)/m';
$str = 'RedWings-223123-NY
Townmansion-2341322-KY
BearingWays-23422-DC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);