re = /^(?:Bear|Town|Red)/m
str = 'RedWings-223123-NY
Townmansion-2341322-KY
BearingWays-23422-DC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end