using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=partNumber=)[\w-]+|(?<=/)\d+$";
string input = @"https://www.opsm.com.au/ProductDisplay?urlRequestType=Base&catalogId=12601&categoryId=3074457345616695670&seoNameToken=air-optix-colors-2pk&langId=-1&manufacturer=AIR+OPTIX&facetTokenValue=facet-lifecycle%3DMONTHLY&partNumber=ac-airoptix-colors-2&storeId=10151
https://www.opsm.com.au/womens-sunglasses/ov5514su-kasdan/827934482050";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}