use strict;
my $str = 'https://www.opsm.com.au/ProductDisplay?urlRequestType=Base&catalogId=12601&categoryId=3074457345616695670&seoNameToken=air-optix-colors-2pk&langId=-1&manufacturer=AIR+OPTIX&facetTokenValue=facet-lifecycle%3DMONTHLY&partNumber=ac-airoptix-colors-2&storeId=10151
https://www.opsm.com.au/womens-sunglasses/ov5514su-kasdan/827934482050';
my $regex = qr/(?<=partNumber=)[\w-]+|(?<=/)\d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}