re = /(?<=partNumber=)[\w-]+|(?<=\/)\d+$/m
str = 'https://www.opsm.com.au/ProductDisplay?urlRequestType=Base&catalogId=12601&categoryId=3074457345616695670&seoNameToken=air-optix-colors-2pk&langId=-1&manufacturer=AIR+OPTIX&facetTokenValue=facet-lifecycle%3DMONTHLY&partNumber=ac-airoptix-colors-2&storeId=10151
https://www.opsm.com.au/womens-sunglasses/ov5514su-kasdan/827934482050'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end