#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|;)([^\n;]+)(?=.*(?:(?<=^|;)\1(?=;|$)))"
Local $sString = "foo;bar;123;foo;123;" & @CRLF & _
"foo;bar;foo;bar;" & @CRLF & _
"foo;bar;123;myfoo;123;" & @CRLF & _
"something with spaces; something else;something with spaces"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")