re = /(?<=^|;)([^\n;]+)(?=.*(?:(?<=^|;)\1(?=;|$)))/m
str = 'foo;bar;123;foo;123;
foo;bar;foo;bar;
foo;bar;123;myfoo;123;
something with spaces; something else;something with spaces'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end