$re = '~(?<=^|;)([^\n;]+)(?=.*(?:(?<=^|;)\1(?=;|$)))~m';
$str = 'foo;bar;123;foo;123;
foo;bar;foo;bar;
foo;bar;123;myfoo;123;
something with spaces; something else;something with spaces';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);