package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*\/products\/[^\/]+\/productDetail\/[^\/]+\/$`)
var str = `/eshop/products/SMART+TV+SAMSUNG+UE55H6500SLXXH+3D/productDetail/ger_20295028/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}