$re = '/^.*\/products\/[^\/]+\/productDetail\/[^\/]+\/$/';
$str = '/eshop/products/SMART+TV+SAMSUNG+UE55H6500SLXXH+3D/productDetail/ger_20295028/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);