const regex = /^.*\/products\/[^\/]+\/productDetail\/[^\/]+\/$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\\/products\\\/[^\\\/]+\\\/productDetail\\\/[^\\\/]+\\\/$', 'g')
const str = `/eshop/products/SMART+TV+SAMSUNG+UE55H6500SLXXH+3D/productDetail/ger_20295028/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}