package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:\.\d+)?|(?:[^\w\s]|_)+|[^\W\d_]+`)
var str = `I2eat!Apples22becauseilike?Them
I2eat!Apples22becauseilike?ThemBLEU34.56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}