re = /\d+(?:\.\d+)?|(?:[^\w\s]|_)+|[^\W\d_]+/m
str = 'I2eat!Apples22becauseilike?Them
I2eat!Apples22becauseilike?ThemBLEU34.56'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end