package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]+(?:(?:[._]|__|-*)[a-z0-9]+)*$`)
var str = `a.a
a_a
a__a
a-a
a--a
a---a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}