$re = '/^[a-z0-9]+(?:(?:[._]|__|-*)[a-z0-9]+)*$/m';
$str = 'a.a
a_a
a__a
a-a
a--a
a---a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);