// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]+(?:(?:[._]|__|-*)[a-z0-9]+)*$").unwrap();
let string = "a.a
a_a
a__a
a-a
a--a
a---a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}