const regex = new RegExp('([a-zA-z]+)(\\d+)(?:,?)', 'gm')
const str = `skmem:(r0,rb572928,t0,tb87040,f0,w0,o0,bl0,d0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}