// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-z]+)(\d+)(?:,?)").unwrap();
let string = "skmem:(r0,rb572928,t0,tb87040,f0,w0,o0,bl0,d0)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}