re = /([a-zA-z]+)(\d+)(?:,?)/m
str = 'skmem:(r0,rb572928,t0,tb87040,f0,w0,o0,bl0,d0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end