#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?P<name>[A-Z_-]+)\s+" & @CRLF & _
"(?P<body>\{" & @CRLF & _
" (?:(?:[^{}]+)|(?2))+" & @CRLF & _
"\})"
Local $sString = "CPE-MGT {" & @CRLF & _
" instance-type virtual-router;" & @CRLF & _
" interface ge-0/0/0.0;" & @CRLF & _
" routing-options {" & @CRLF & _
" static {" & @CRLF & _
" route 192.168.253.115/32 next-hop 192.168.100.1;" & @CRLF & _
" route 0.0.0.0/0 next-hop 192.168.100.1;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"DATA {" & @CRLF & _
" instance-type virtual-router;" & @CRLF & _
" interface ge-0/0/1.0;" & @CRLF & _
"}" & @CRLF & _
"MGMT_BK {" & @CRLF & _
" instance-type virtual-router;" & @CRLF & _
" interface ge-0/0/2.0;" & @CRLF & _
" routing-options {" & @CRLF & _
" static {" & @CRLF & _
" route 192.168.253.115/32 next-hop 192.168.100.1;" & @CRLF & _
" route 0.0.0.0/0 next-hop 192.168.100.1;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")